Need massive help - could not connect to wicd’s D-bus interface


#1

I’m not new to Linux but I’m completely thrown for a loop with this. My comp got stolen out of my car. Got a cheap comp from my brother I cleaned it and decided what the hell I’ll try Kali on this computer. So I installed it strait to my HD . Once installed and booted up I noticed that there was an error message saying ( could not connect to wicd’s D-bus interface. Check the wicd log for error messages.) I did and it was empty. Then got another error (The wicd daemon has shut down. The UI will not function properly until it is restarted.) I have absolutely no internet yet all other devices are working normally. I tried to look for the settings yet there is no icon. Infact my screen looks nothing like I’ve ever seen a Linux screen look before. I have no root terminal the only terminal I was able to find was the LXTerminal. I ran my ip and it registers nothing I pinged 8.8.8.8 and it was unsuccessful. I tried ifconfig and it’s not recognized. And having no internet access I cannot update or add network-tools to fix the issue. If someone could please step by step with me I’d be extremely appreciative. Thanks


#2

Hi John,

A nice setup you got there, seems like many issues at once. Please provide some additional information, so we can narrow down the possible problems.

What version of Kali are you running?

Do you get an IP address? To get that simply run ip a, should work on non-root termial.

Also, do you have wifi or cable connected network?
Please also provide the output of systemctl status NetworkManager -l if you are running NWM.

Let’s clear this a bit, you can’t sudo or su root to get a root session? If so, please paste the output of the sudo command. By default Kali only have the root user, did you created another unprivileged one that you logged in with?


#3

Ip a Returned as 000.000.000.00
Su root returned an authentication failure

I tried wireless and wired connections.

Using Kali 2018.3 and no I didn’t create a different privileged user to log in with I’m on my admin


#4

Hi John,

Please provide the output of the following command:

systemctl status wicd.service

So we can verify the service’s systemd settings. Seems to be an issue with more than one distros.


#5

I am facing the same issue.

I ran systemctrl status wicd.service

Output
wicd.service - Wicd a wireless and wired network manager for Linux
Loaded : loaded (/lib/systemd/system/wicd.service; disabled; vendor preset; disabled)
Active: Inactive (dead)
Docs: man:wicd(8)


#6

Hey Disco,

Welcome to our forums.

Your setup seems to not use wicd at all; before trying it, please verify that you don’t use something else, like NetworkManager:

systemctl status NetworkManager

If that is disabled and vendor preset; disabled as well, give wicd a try with

systemctl start wicd


#7

Hello sandmann,

Thank you for great help. I have checked system no NetworkManager found but command systemctl start wicd works !! :slight_smile:

Feeling lucky posted my query at right place !!


#8

Hey Disco,

I’m happy it worked nicely. You’ll probably also want to set wicd to automatically start on reboot with the following:

systemctl enable wicd


#9

Hi Sandmann,

You are awsome !! Am about to ask this question and opened this window to rais this query but lucky I saw this message answered by you already… Thanks for your support…


#10

Hi Disco,

Happy to help. The usage of a service and the need to start it on startup are related, so it was a bit more than a guess :wink: