Password requested for DNS info?

I have four Debian 10 AD DC VMs running Samba 4.14 as a test bed to learn how to navigate installation and management of such a setup. The first DC provisioned just fine. The second DC joined the domain fine. The second two had to have samba-tool dns-update run on them to create the SRV files. In trying to look into this I tried running the command:

carrot@server1:~ $ sudo samba-tool dns zonelist server1
Password for [CARROTNET\root]:

I tried the root password for the server1 VM, nope. Tried the password for the domain admin, nope. Tried the password for the user carrot, nope. Other than the root user for server1, I can’t think of what root password is being requested here. What am I missing? How do I run this command?

Thanks in advance for the help!

Hi Robert_Spradlin,

Welcome to our forums.

I am far from being a samba expert or anything, but I have a guess that may help with your issue. The prompt for the password gives me a clue:

From it’s format it seems like a <domain>\<user> credential, not a <user>@<host> credential - in other worlds, the password of the root user is needed on the CARROTNET domain, not a local user’s password.