RHEL 7 - Solution to "There are no enabled repos" message - LinuxConfig.org

The error message bellow will be display on your Redhat 7 linux system after a fresh RHEL 7 system installation. It simply means that in order to get system updates and also to install new software you need to configure package repositories.
This is a companion discussion topic for the original entry at https://linuxconfig.org/rhel-7-solution-to-there-are-no-enabled-repos-message

Cristóbal Belda

Nice article!

But actually something fails for me.

file:///media/rhel7-repo-iso/repodata/repomd.xml: [Errno 14] curl#37 - “Couldn’t open file /media/rhel7-repo-iso/repodata/repomd.xml”
Trying other mirror.
file:///media/rhel7-repo-iso/repodata/repomd.xml: [Errno 14] curl#37 - “Couldn’t open file /media/rhel7-repo-iso/repodata/repomd.xml”
Trying other mirror.
repolist: 0

Did anyone experience this?

Thanks a lot in advance!


I do not have /dev/cdrom . So where do i mount?


Thank you for sharing this. This what I needed



Hi, thanks for the solution. I got rid of the issue following the solution in this. However, I am unable to install any new packages using yum. I get below message, any idea ?
[manmp@localhost ~] sudo yum install apt-get [sudo] password for manmp: Failed to set locale, defaulting to C Loaded plugins: product-id, search-disabled-repos, subscription-manager This system is not registered with an entitlement server. You can use subscription-manager to register. No package apt-get available. Error: Nothing to do [manmp@localhost ~]

I believe yum is now trying to look for packages within local repo. How do i make yum to look for packages to install in local repo from Internet?

Hi Manjunath_M_P,

Welcome to our forums.

The error message you posted simply mean there isn’t an apt-get package available in the configured repository. On RHEL yum will always note that you are not registered - as long as you got the subscription-manager yum plugin installed.

Please explain the following:

Your system seems to look into the local repository already, which does not contain the package you asked for.