Ubuntu gnome desktop is crashing daily


#1

my upgrade to 18.04 webt smoothly.
One big problem! on a daily basis the system crashes!
The mouse click are not processed nor the keyboard.

Research informed me that this is a gnome desktop problem.

I’m keen on KDE and tried to install with your instructions however your command.
sudo tasksel install kubuntu-desktop also fails!

tasksel: apt-get failed (100)

can anybody helo


#2

Hi Xtrick,

Welcome to our forums.

About stabilizing the Gnome desktop: please try to add another user to the computer, and switch to it. Check if the problem persists there. If not, the problem is with your user profile, not Gnome. Had a similar problem once.
About the error message: can you find anything relevant in the logs regarding the tasksel: apt-get failed (100) message (maybe in /var/log/syslog)? Does an apt-get update and apt-get upgrade work, or giving the same error?


#3

Hi,

Thanks for your advice.
I’ve just experienced a day without a crash!
I conclude that the upgrade to 18.04 did not properly takeover my account - that can only be the explanation.Maybe this should be reported?
i had no problem with apt get upgrade.
Before getting the apt-get failure it had downloaded at least something like 26 packages successfully. Is the code 100 meaning NOT FOUND or something similar?


#4

Hi,

the apt error code 100 could mean many things but most likely it is related to your repository settings. For example, that your repository index is not updated or some of your repositories fail to download update file/package etc. It is also possible that apt is used by GUI package manager, hence it locked, at the same time you execute tasksel command.

Check whether you see any errors/warnings when executing sudo apt update command. Also review the /etc/apt/sources.list file. Possibly disable any 3rd-party repositories to narrow down the cause of the apt error code 100.

Lubos


#5

Hi,

About restoring your original user’s graphical session: as you can work without crash with a fresh user, the problem will be some session files in your original $HOME directory. To debug that you can move some GUI-related (and possibly hidden) directories away from there (like .cache, .config or .gnome), one at a time, and see if one of it solves the issue. Note that moving these may cause some of your GUI settings to be lost until you move the directories back.
You should also have crash report(s) somewhere in your home directory that may also be hidden and start with something like .xsession that could show what crashes your session.


#6

here is my sources list below. Sudo apt update works

# deb cdrom:[Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426)]/ bionic main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://gb.archive.ubuntu.com/ubuntu/ bionic main restricted
# deb-src http://gb.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb-src http://gb.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://gb.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://gb.archive.ubuntu.com/ubuntu/ bionic universe
deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://gb.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://gb.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://gb.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://gb.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb-src http://gb.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://security.ubuntu.com/ubuntu bionic-security main restricted
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse
# deb-src http://archive.canonical.com/ubuntu bionic partner
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse

#7

Have you tried to consult any relevant log files to see if you can find something suspicious? Good place to start will be the /var/log/apt/ directory and namely log file term.log.

Also just in case please try to remove any cached packages before running tasksel again:

$ sudo apt clean