VNC server on Ubuntu 18.04 Bionic Beaver Linux - LinuxConfig.org


#1

To install xvnc4viewer on your Ubuntu client system run:

If all went well, you will be presented with a Xfce4 desktop session running on the remote VNC server Ubuntu system:


This is a companion discussion topic for the original entry at https://linuxconfig.org/vnc-server-on-ubuntu-18-04-bionic-beaver-linux

#2

I have this error using this article:

Unable to contact settings server. Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.


When i click close its give me one more error only quit button is exist
I use termux on android using ubuntu server 18.04 and android again for client using VNC Viewer app, server using vnc4server.


#3

Hard to say, but I would try to follow the suggestions shown on the actual error message.

  1. Are you able to correctly connect from some other vnc client
  2. is it possible that the outgoing traffic from VNC server is blocked
  3. Are you trying to connect via port forward? Is locally everything working as should

#4

Hi. I followed exactly all the steps in the article and when I try to connect to my VNC server, it works however I get a grey screen. When I do it from the same machine, to test from localhost, I get also grey screen and the icon in the taskbar on my ubuntu desktop has a sort of “unauthorized action” icon, circle with diagonal bar to it.
Same when attempting from my laptop using win10 and ultraVNC client. Help?
what am i doing wrong?
thanks in advance.
update: I tried again to do the VNC server setup steps, nothing changed.


#5

Hello,

This seems to be a VNC server setup issue. Most likely the xfce session does not start. Have you tried to repeat the VNC server on Ubuntu 18.04 Bionic Beaver Linux - LinuxConfig.org section?

Lubos


#6


here is what I see from my windows client.


#7

I found a temporary workaround.
In the Ubuntu VNC server setup, I repeated the steps setting password
to starting the vnc4server all that as root doing sudo su.
After that I was able to connect to my vnc server from the client I had installed in windows.
That means my original setup, following the steps carefully was missing something in launching the xfce session.


#8

I had the same grey screen problem. Using the following xstartup file solved it.

#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
startxfce4 &

I found the solution on this forum: