Overclock Your Radeon GPU With AMDGPU - LinuxConfig.org


#1

In order to make sure that it worked, run sensors, and see if your card is there. Try restarting the lm-sensors service if you don't see your card there.


This is a companion discussion topic for the original entry at https://linuxconfig.org/overclock-your-radeon-gpu-with-amdgpu

#2

Sean Bergstedt

Any way to reduce power usage/wattage through this method?


#3

Johnny Myers

thanks this works perfect, just start with sudo su then put in your commands after


#4

Philippe Couture

Sorry but this tutorial just does not work. The fan speed is the only thing working fine.
I have 18.4m,h/s with my msi Gaming Rx580.
On windows10 It was about 20 mh/s.

for example -> echo “8” > /sys/class/drm/card0/device/pp_sclk_od
make GPU0 and GPU1 drop ?!?!?
WTF I though it was GPU0 and I though it was suppose to increase mh/s not droping it.
Why it make 2 GPU drop ???

After 30 seconds it goes back to 18.4 mh/s.

Don’t buy this RX580 GPU for mining


#5

Robert Ruedisueli -> Philippe Couture

This is because you are overheating.

Radeon GPUS are heat throttled. If they overheat they start reducing their clock speed.

If you don’t care about noise, try setting the fan to maximum, and increasing the airflow around the rig by other means.


#6

Marek

Hello everyone

I was able to change memory and system clock with the echo command

amdgpu_pm_info confirms higher frequency

But ethminer hashrate remains exactly the same as before overclock.

I did not flash mi bios yet.

Do you have any ideas why I dont see even a minimal hashrate increase?
Any help is highly appreciated.

I have RX570 nitro+ 4GB
Drivers are amdgpu-pro 17.40.3.12
Kernel 4.10.0-28 (wasnt able to get the pro drivers to work on newer kernel)


#7

Justin Waulters

I got this to work with amdgpu-pro by editing the files using gksudo and leafpad. For some reason echoing the command directly into the file gives permission errors (even as super user).

I have been running into one problem.
when running amdgpu_pm_info I can see the mclk MHz go up as I increase the variable in the pp_mclk_od file. However, I can only get it up to a certain level.
In my case, it seems like the upper limit is 20 (which ends up being 2100MHz).
My card is very stable at this level and I want to go further, but even if I put in 40 or 50 the MHz doesn’t increase over 2100.

Is there some limiting factor in this driver, and if so how do I disable it?

I know I can change the card’s BIOS, but this would be such a petter solution for my case if I could get it to increase as much as I want.


#8

mvpel

On the new 17.40 driver it’s necessary to enable the i2c engine with a driver parameter, hw_i2c, with this line at the end of /etc/default/grub:

GRUB_CMDLINE_LINUX="$GRUB_CMDLINE_LINUX amdgpu.vm_fragment_size=9 amdgpu.hw_i2c=1"

Otherwise the “hwinfo” files do not appear.


#9

mvpel

It appears that pwm1 is a range from 0 to 255, rather than percentage, based on pwm1_max and pwm1_min on driver 17.40 with an RX570.


#10

nick

Why does this not stick after a reboot?


#11

mvpel -> nick

You need to put it in a startup script. This is normal for Linux.


#12

Areeb Soo Yasir

I’ve tried this but it doesn’t seem to work with the latest drivers 17.40-492261

sudo echo “5” > /sys/class/drm/card0/device/pp_mclk_od
-bash: /sys/class/drm/card0/device/pp_mclk_od: Permission denied

I’m going to try OhGodATool next to see if it still works.
Cheers


#13

Duh -> Areeb Soo Yasir

That’s because sudo is only applying to the echo. Use tee or sudo su - first.


#14

sc3pilot -> Areeb Soo Yasir

This method only works with the amdgpu drivers that come with Linux. It does not work with the AMD Pro drivers.


#15

Stevie -> sc3pilot

Does it mean I cant overclock rx 500 Cards?


#16

Justin Waulters -> sc3pilot

I got it to work with amdgpu-pro drivers by opening the file in leafpad using gksudo and editing that way. For some reason, echoing the line directly into the file does not work right for me. I read somewhere that there is a bug regarding this.


#17

Beracira -> Areeb Soo Yasir

the solution i used was to edit the file as root.
i.e. sudo su
and then execute the command


#18

Shaaban Ragab -> Beracira

how can i under volt gpu and how to decrease core frequency


#19

FaceSpace -> Shaaban Ragab

polaris bios editor… there’s a linux version of it on github


#20

Alexandr Minzak

I One strange card Nitro+ RX570 8G, Under windows10 - all is fine, but under debian wont work:
0 MHz MCLK and 0 MHz SCLK and hashrate usual “-” or some time up to 100 (cryptonight)

And system file too slowly open like this:
/sys/class/drm/card2/device/pp_sclk_od
/sys/class/drm/card2/device/pp_mclk_od
/sys/kernel/debug/dri/2/amdgpu_pm_info

like hung, but 2-4 second need to get data from this files.

P.S. Cable, Razer - it is not matter, because under Windows all is fine.

WTF ?