Persistent Back-Up

I’m getting closer and closer to saying Good-Bye to Windows, Thanks to all the help I’ve received through LinuxConfig forums, You all really know your stuff.

Now, I want to make a Persistent Back up on a 16 GB SanDisk thumb drive, I’m happy with how the laptop configuration is working, I would like to clone it, and be able to put it on my desktop.

I’ve tried a few tutorials I’ve seen on the web, but can never quite finish up. I’m okay with the mkusp, That I have loaded, my problem up to now is when prompted for the destination drive, I can see it, I can highlight it…but there is no green GO, it’s grey. It has to be something basic I’m missing?



My first guess would be that the USB drive is already formatted, so mkusb puts on a safety belt to protect you from overwriting potentially valuable data. If that is so, you’ll need to delete the partition already on the stick in order to proceed. I guess I don’t need to say: back up any data needed from the USB drive before deleting the partition.


I think I had better stop thinking. I thought I had it formatted, but thought wrong.

The 16GB flash drive showed only 14.91 GB of free space, So there must have been a partition on it, I couldn’t see any partitions with Gparted, should I have done the format in an alternate method?

I believe the drive is now trashed, I can’t read it in either Ubuntu or Windows. In windows it tells me the drive needs to be formatted, it’s not recognized at all in Ubuntu.

Is it trashed or salvageable? It’s not a week old. I guess I messed up big time huh?

Thank-You Sandmann

Try this:

Insert your USB flash drive into your Linux box. Execute:

# fdisk -l

Next, locate your USB flash drive block device name. It will be something like /dev/sdX etc where X is [a-z]. Strip partition table with cfdisk command:

WARNING: Make sure you get the block device name right as the bellow command has a potential to destroy your system disk and data.

# cfdisk -z /dev/sdX

Select label type, DO NOT create partition, write changes and retry your mkusb backup.

So far, So good. I did get the USB formatted correct this time, there isn’t that minute little partition on the right any more. A good thing.

I’ll finish in the morning. There was a time that I could stay up all night and work on the computer, 3 days after I applied for social security I ended up in the hospital for 2 weeks with end stage kidney failure. Now I sleep all day. A huge change for me.

Okay, I tried that Lubos, I’m going to attempt to post a screen shot of what displayed, it may help?

I tried it with using sudo and without, I wasn’t sure on that. The USB is the only one connected to the laptop.

Thank You again

Hi there, please distinguish between your system’s configuration and your user’s configuration. On desktop linuxes there usually is not much to set up in the system and most settings are user specific, that means stored in the home-folder of a user. Blindly copying over system configuration files from one device to the other can do more harm than good. I would therefore recommend to set up the Linux on the second device, create a user with the same name as on the first device and then restore a backup of the user’s home folder from the first device to the second. A nice tool for this is Déjà Dup which is available on many distributions. Déjà Dup backs of your user folder (with settings) to an external device (e.g. you thumb drive) and even offers encryption.

So pretty much, a persistent back-up on a thumb drive isn’t all I thought it would be? I’m better off doing a fresh install on each computer? That’s kind of a let down, I eventually want to put Ubuntu on each computer in the house…we have 6. I’m really liking Ubuntu, always thought Windows was the bomb, but Windows 10 really put a nasty taste in my mouth.


Yes, doing a fresh install is what I recommend. Most system settings are done by the installer anyways. I for example only use Linux (im my case Fedora). When I set up a new computer I run the installer, set up my user account and then run a script I put together for myself to install all the tools I need. After this I reconnect my cloud accounts and am good to go. Scripting a standard setup has another advantage: My software is always up to date. Depending on your Linux distribution you will face weekly or monthly updates. Copying over the whole system from one machine to the other is not very practical because you will always start with an outdated system.

By the way: Admins, who have to roll out many linux servers automatically often use tools like ansible or puppet. These tools also follow a scripted approach to configure systems. For a desktop user at home these tools are far too complex. While reinstalling a server is about setting up services and modifying system files, reinstalling a desktop linux usually means reinstalling the most used apps and copying over the content of the home folder. The latter can be done with the program I mentioned earlier.


While I also recommend clean install on every device (for practice if no other usage), your printscreen shows that you execute the commands wrong, so let’s clear a misunderstanding:

Here at the forum we use “#” to mark a command to be executed as root, and commands that are preceded by “$” can be (and should be) executed as regular, non-privileged user. These marks are the default ending characters on your terminal’s prompt as root or as normal user (these are covered at the welcome section’s conventions).

You’ll see this marking convention throughout the world, from related books to tutorials down to simple news articles that present some terminal commands.

So in your case, if you type something like:

# fdisk -l

With the “#”, you actually mark it as a comment, and nothing will be executed (the “#” is also the mark of a comment in bash).
When you execute this:

sudo # fdisk -l

You say “sudo” without arguments, so you get an error message.

In such cases we mean “execute fdisk -l on the root terminal”.

I imagine this may be misleading at first glance, and we are so used to it we don’t really think about this could be a problem. But apparently it can. So it is not your fault, but you misused these commands, that’s why they did not work.


I believe I understood most of that, I’m a bit confused still. I’ll try to explain as best I can. Using your fdisk as an example. Let me know how I did, or if I’m just confusing you more. I’m still the only user, I guess the term is Super User, I have no other users added, as of yet. So that would make me a privileged user?

So, as I’m understang it, I should enter the command as # fdisk -l, and not as sudo # fdisk -l? or is it the other way around? That is where I am becoming confused. I have noticed the #, but never truly understood it. I do appreciate all the effort and time you’ve given with your assistance.

I’m hoping someday I’ll be able to offer help and assistance just as Lubos, bedawi & yourself have given me.

Thank You

Hi BADDC0, just replace the “#” with “sudo” and ignore the “$”.

# echo test
you type in
sudo echo test

Example 2:
$ echo test2
you type in
echo test2

The # and $ are just writing conventions indicating wether or not a command has to be executed privileged (sudo). They are not actually part of the command.

1 Like

Thank You, Now that made sense, I don’t feel like such a Dufus. I was on the rght train of thought then, made me feel better.

You’re welcome. This syntax can be confusing but you’ll find it very often in the Linux context. :grin: