Virtualbox: install guest additions on Redhat 8 -

In this tutorial we will be installing the Virtualbox guest additions on Redhat 8 Linux. Virtualbox guest additions allows for better screen resolution and mouse integration.
This is a companion discussion topic for the original entry at

Does not work with CentOS8 and Virtualbox 6.0.6 – I have tried multiple installations with no success. RHEL8 Works.

What particular issues do you have? More information is needed… I was following the guide just yesterday on Virtualbox 6.0.10 with CentOS 8 and no problems:

I am having issues with CentOS 8 and VB 6.0.12, when running I get error “Extraction failed. Signal caught, cleaning up” and returns to prompt. Its driving me nuts…

Hi Robert_Wideman,

Welcome to our forums.

Did you run the installer with root privileges? If so, you may also be out of disk space on the virtual machine.

Thanks, yes I did. I was following guide, running on MacOS and configuring CentOS 8.

Did you get an output line which is something like the following:

Verifying archive integrity … All good.

Or the first message you got is this “Extraction failed” before the installer exited?

Here is the full output of ./

Verifying archive integrity… All good.
Uncompressing VirtualBox 6.0.12 Guest Addisions for Linux.Extraction failed.
Signal caught, cleaning up

Hi Robert,

To further narrow possible problems, I’d suggest copy the whole script onto the local filesystem, and test an execution from there. Please provide the output if not exactly the same as before.

I did and it gave the exact same output

I deleted that VM and tried again only to have it fail the same way. I had another CentOS 8 with GUI VM so I tested that and it works just fine. Weird as I am unable to create a vagrant box. LINK REMOVED

I faced the same issue when installing Guest Addition on Centos 8, you may lack of tar and bzip2 library, file is a self extracted file using this library “makeself”, so the system must have uncompression library for it to self-extract probably

I get the same error as many people all over the internet:

Upon creating a new, minimal centos8 vm,
update yum
install kernel headers and development
reboot onto new kernel
install additional packages as indicated
downloaded latest GA via link provided above (though also get same error with the ones provided with VB 6.0.14)
mount the iso
sudo to root
copy cdrom to /tmp
run and get:

Verifying archive integrity… All good.
Uncompressing VirtualBox 6.0.15 Guest Additions for Linux.Extraction failed.
Signal caught, cleaning up

I have plenty of space on the drive.
I have all the packages installed.

Something is missing but I know not what. Judging by remedy by others - a fuller installation (ie. one with UI) seems to get around this.

Got it!

My minimal Centos 8 install needed tar and bzip2. It is now extracting.

Hi obwon,
Confirmed. I was also able to replicate Guest Additions for Linux.Extraction failed. error on a minimal CentOS/RHEL 8 installation using basic gnome-shell install:

As you suggested this error can be resolved by installation of both tar and bzip2 packages.
Thank you for looking into this. The article will be updated shortly.


Trying to install Guest Additions in RHEL 8.2.

VirtualBox Guest Additions: Starting.
VirtualBox Guest Additions: Building the VirtualBox Guest Additions kernel
modules. This may take a while.
VirtualBox Guest Additions: To build modules for other installed kernels, run
VirtualBox Guest Additions: /sbin/rcvboxadd quicksetup
VirtualBox Guest Additions: or
VirtualBox Guest Additions: /sbin/rcvboxadd quicksetup all
VirtualBox Guest Additions: Building the modules for kernel

VirtualBox Guest Additions: Look at /var/log/vboxadd-setup.log to find out what
went wrong
ValueError: File context for /opt/VBoxGuestAdditions-6.0.20/other/mount.vboxsf already defined
VirtualBox Guest Additions: Running kernel modules will not be replaced until
the system is restarted
Press Return to close this window…

No idea what to do next. Been trying for sometime.

Hi Wayne_Boxall,

Welcome to our forums.

From the error message it seems as if the guest additions are already installed. Did you try to install more than once?

About the ValueError message: is /opt/VBoxGuestAdditions-6.0.20/other/mount.vboxsf file present on the system?

1 Like

No this was the first install and I know they aren’t working as the resolution of the VM is screwed.

I will check the mount.vboxsf file.

Thanks heaps for a response.

I have the same issue and get the same exact message, were you able to properly insert guest additions to have better resolutions like a true full screen, copy paste…

/opt/VBoxGuestAdditions-6.0.20/other/mount.vboxsf is present but would not have been when I first tried to install the additions.

I may need to wait for Vbox to catch up with the latest RHEL support.